[Special Summer Sale] 40% OFF All Magento 2 Themes

Cart

PHP Settings to ignore the WordPress error

  • This topic is empty.
Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #10654
    raju-raja
    Participant

    I want to run wordpress site under sartajphp framework. When i run wordpress site normally it worked fine. It may be ignore erros. But when i tried run under sartajphp it gives following php error.

    SartajPHP Fatel Error:- Type:-8192 Msg:-Implicit conversion from float 4294967295 to int loses precision File:-D:\www\demo\apps\wordpress\wp-includes\pomo\mo.php on line no. 208 
    

    Below is wordpress file error code:-

    $magic_big = ( (int) - 569244523 ) & 0xFFFFFFFF;
    

    If i write a small value in this line then it worked fine. Is there any INI settings to ignore this error?
    It is wordpress file so i don’t want to modify it. So is there any good solution for this problem.

    This code is working:- $magic_big = ( (int) – 569244523 ) & 0xFFFFFF;

    #10655
    ken-lee
    Participant

    Errors should normally be good for telling you something went wrong

    But if you really want, due to some special purposes, to hide Php errors in WP, then

    Open Your wp-config. php File.

    Replace the Debug Lines. Replace the existing lines with the following code snippet:

    ini_set('display_errors','Off'); 
    ini_set('error_reporting', E_ALL ); 
    define('WP_DEBUG', false); 
    define('WP_DEBUG_DISPLAY', false);
    

    Save and Upload.

    Alternatively, if you can access the php.ini file, then use the following line (restart your httpd after changing the ini file):

    display_errors = On
    
Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.